We will be undergoing scheduled maintenance during this time.
Posted Nov 04, 2025 - 14:39 UTC
Scheduled
We'll be performing scheduled maintenance on Thursday, November 6, from 20:00 to 22:00 UTC. During this 2-hour window, you may experience brief service interruptions when accessing the Support Customer Portal. Chat and email services will be unaffected.
Posted Oct 30, 2025 - 17:44 UTC
This scheduled maintenance affects: Support Service (Customer Portal).